Request for Changes-19: SuperBuild version update before 5.2

From OTBWiki
Jump to: navigation, search

[Request for Changes - 19] SuperBuild version update before 5.2

Status

Summary

The versions of the libraries in the SuperBuild will be updated. OSSIM update is needed to support Sentinel-1 calibration, other updates should be only patch update.

Rationale

See Request for Comments-15: Update Superbuild third parties

Implementation details

Classes and files

The following versions will be updated :

  • OSSIM : r23537 -> 1.8.20-1 : serious bug in 1.8.20-1
  • FreeType : 2.6 -> 2.6.1 : actually need a dependency (Harfbuzz) that is not handled by SuperBuild
  • GeoTIFF : 1.4.0 -> 1.4.1
  • ITK : 4.8.0 -> 4.8.1
  • JPEG : 1.4.1 -> 1.4.2 : difficult : CMake scripts don't work well, automake scripts need version 1.15
  • LIBKML : 1.3.0-r863 -> 1.3.0-rc0 : not trivial, leave it for later
  • muParser : 2.2.3 -> 2.2.5
  • OpenCV : 2.4.10 -> 2.4.11
  • OpenSSL : 1.0.1e -> 1.0.1p
  • Qt : 4.8.6 -> 4.8.7
  • Swig : 3.0.5 -> 3.0.7
  • TIFF : 4.0.3 -> 4.0.6

Applications

Tests

Documentation

Additional notes